2Pint Software – The Home Of Microsoft P2P Extensions Forums Public Forums All About Peer To Peer Is IPv6 required to be enabled for BR Reporter?

  • Author
    Posts
  • Todd Miller
    Post count: 0
    #16386 |

    I have installed BC Reporter on one client and deployed a BC enabled advertisement to that client. Upon receipt of the package at the client, there was an error displayed on the machine involving BITSBCReporter.exe. The error was recoreded in the system’s application event log. In my org, we have IPv6 disabked on the clients by setting TCPIP6/parameters/Disabledcomponents set to 0xffffffff Is IPv6 required to be enabled for the reporting tool to work without error?

    The text of the entry for BITSBCReporter.exe is below.

    Application: BITSBCReporter.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: System.Net.NetworkInformation.NetworkInformationException
    at System.Net.NetworkInformation.SystemIPInterfaceProperties.GetIPv6Properties()

  • Phil Wilcock
    Keymaster
    Post count: 25

    hi Todd,

    NO need for IP6.

    it’s a known issue, fixed in the next release which is due any day now.

    The workaround is to create a reg key – HKLM:\Software\2Pint Software\BCReporter

    and a DWORD value named IncludePolicyStats which should be set to 0

    thanks
    Phil

  • Todd Miller
    Post count: 0

    When I looked, that value was already present in the registry and set to 0. Maybe the code sets it this way on its own if an error is encountered?

    I have a second problem where the logs are hanging while attempting to capture the MAC address, but I will open another thread as it is a separate issue I think.

    • Andreas Hammarskjöld
      Keymaster
      Post count: 64

      Hmmm,

      I think a debug log would be a good start. That version of the Reporter had a few known issues. Or hold off until tomorrow (or whenever Phil can get his updated reports finalized).

      //A

You must be logged in to reply to this topic.